I think this patch is fine.
I think (1) can be fixed quite easily. What do you mean when you say that (2) would result in a performance decrease? Would this only be in an error situation or also during regular runtime?


Andi

At 01:05 PM 9/12/2003 +0200, Marcus Börger wrote:
Hello internals,

  after last discussion on this list regarding PHP's naming convention for
OOCode i took a deeper look at fixing my main concerns. That is error
messages, backtraces and reflection show lowercased method names. However
this is easily changeable; with a minor performance decrease at compiletime
when handling methods (not functions).

The attached patch now changes two files for two different purposes:
1) Zend/zend_compile.c, These changes allow to show the original
function/method names in errors, backtraces and reflection. This works for
internal as well as for user functions/methods.

2) Zend/zend_default_classes.c, changes the method names of the internal
exception class to studlyCaps naming convention.

The patches were already tested by some other developers and we found out
thefollowing things:
1) Some few error messsages show the new method name but should show the old
method. For example when trying to override a final method the new name is
shown instead of the old one which the message states.

2) Errors for non existing functions are still shown lowercased. This could
be changed too. But the performance decrease is higher so i wouldn't
recommend that.

I think decision whether to incorporate this patch is up to Zeev and Andi.

--
Best regards,
 Marcus                          mailto:[EMAIL PROTECTED]

-- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php



Reply via email to