I'm not really anxcious to have an anyempty() function, but I do think
empty() should behalve like an allempty() just like isset() behaves like an
areallset(). I guess the "weirdness" is in the fact that isset() will give a
positive reply when something exists, while empty() gives a negative reply
when something exists. I guess this creates the confusion and would make the
allempty() functionality less likely to be used often. I guess people will
want to check more often if all their vars are set, and therefor an "or"
situation instead of "and" would be more suitable, because then you could
do: if (empty($var1, $var2, $var3)) echo "there's an empty var";
I'd personally prefer the "and" situation, but it's a fact that this would
make it far less useful than the "or". So I can see the confusion and the
reason to just stick with 1 parameter.

I guess there should just be a function like isset() which returns !empty().
Maybe it should be called isval() or something. Then it could be used for
several vars without confusion:
if (!isval($var1, $var2, $var3)) return "there's an empty var";

This would make sense to everybody I think, because like isset() it would be
an "and" situation.

Ron


"Jevon Wright" <[EMAIL PROTECTED]> wrote in message
news:[EMAIL PROTECTED]
> How about anyempty($var1, $var2, $var3, ...) ?
>
> Jevon
>
> ----- Original Message ----- 
> From: "Ron Korving" <[EMAIL PROTECTED]>
> To: <[EMAIL PROTECTED]>
> Sent: Thursday, October 21, 2004 12:21 AM
> Subject: Re: [PHP-DEV] suggestion: empty() with infinite parameters like
> isset()
>
>
> > Maybe it was a bad example. Writing "data missing" I was thinking that
at
> > least one variable should be set.
> >
> > Ron
> >
> > "Derick Rethans" <[EMAIL PROTECTED]> schreef in bericht
> > news:[EMAIL PROTECTED]
> > > On Wed, 20 Oct 2004, Ron Korving wrote:
> > >
> > > > Okay, I don't wanna make remarks that may have already been made
> > earlier,
> > > > but I think it should be "all should be empty", because it works
> exactly
> > the
> > > > same for isset(), and apparently, a decision was made to give
isset()
> > that
> > > > feature.
> > >
> > > Right, but then your example would already no longer have worked:
> > >
> > > if (empty($var1, $var2, $var3)) echo "data missing";
> > >
> > > so there is no point in adding it like that.
> > >
> > > Derick
> > >
> > > -- 
> > > Derick Rethans
> > > http://derickrethans.nl | http://ez.no | http://xdebug.org
> >
> > -- 
> > PHP Internals - PHP Runtime Development Mailing List
> > To unsubscribe, visit: http://www.php.net/unsub.php
> >
> >

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to