The only problem is that this is an extension so it would probably have a few functions:
filter_input()
filter_validate()
filter_foobar()


Maybe we were only discussing one method but it's likely for others to follow.

I thinks safe_* is a bit general but then again, although naming is the hardest part of computer science, what the extension does is the most important part :)

Andi

At 04:07 PM 2/1/2005 -0800, Shane Caraveo wrote:
Rasmus Lerdorf wrote:

Andi Gutmans wrote:

I definitely like the idea and thing it's important.
I think as far as the filter functions are concerned this is a good way to go (although I'd change the function name but that's no biggy, filter_input?). I very much see how filter_input(POST, "email", FILTER_EMAIL) is easier as opposed to finding the right regex for emails and it's great re-use.


Yeah, I really don't care what the name of the function is. Wanted to try to keep it somewhat short since it might need to be typed a lot.

I thought my suggestion the other week was pretty good....safe_filter :-)

Shane

-- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php



Reply via email to