Again, you are trying to use a keyword based on what developer's most
know. You want to release a sort of namespace implementation and
frustrate users, that expect a true namespace implementation.

I'd like that language MyPersonalFckinLang implemented it. Everything
in this discussion is motivated by Java does this or C++ or C# or
Python does that.

One package is a specific implementation of namespace which,
unhappilly was incorporated by Java. One package ***IS*** a namespace,
but applies restrictions. WTF? Yes, look at PHP... it's a kind of
namespace implementation (ah packages too), and apply restrictions
(one package per file) (ah, packages too, but namespaces allow more
than one per file).

For your announcement, "PHP has namespace support provided by packages."

I am not the bad guy in this entire history, and I hope we can drink a
dozen bottles of beer =) together in the future, but PLEASE don't
frustrate PHP users by providing them a basic functionality of what
you have announced.

The filescope is another workaround for namespace implementation. One
namespace local import should work in the entire namespace, not only
in the file it was imported.

AGAIN, here are the list of changes that will make everyone accept
namespace as the keyword:

- Remove the restriction to one package/namespace per file
- Use curly braces to define one namespace
- Allow nested definitions namespace N1 { namespace SubN1 { ... }
namespace Sub2N1 { ... } }
- using/import is related to the namespace/package/whatever scope.


If you say these functionalities will be implemented (ok, maybe in
PHP6.1 or 6.X), I'd change my vote and I'll fight in the namespaces
side. I think not only me, but everyone that is currently suggesting
to rename it to packages.
I can even try to help in the development of them, but I'll need some
help to understand the background of ZE. Sara's book will arrive at
home in 4-6 weeks.


Regards,

On 8/17/07, Ilia Alshanetsky <[EMAIL PROTECTED]> wrote:
> David,
>
> Most people don't know wtf you are referring to by "package", but
> nearly everyone knows the concept of namespaces. Packages is name for
> an implementation of namespaces, calling it packages just because
> language XYZ that I like, does not sound like the best of ideas.
>
>
> On 17-Aug-07, at 11:18 AM, David Coallier wrote:
>
> > On 8/17/07, Ilia Alshanetsky <[EMAIL PROTECTED]> wrote:
> >> While PHP implementation of namespaces is may not be 100% of what
> >> people consider to be namespaces it is close enough and I think the
> >> name "namespaces" is most appropriate and clear cut. We don't call
> >> PHP objects "Zend Objects" or some other strange name, I don't see
> >> why namespaces should be any different IMHO.
> >>
> >
> > If we start calling things what they are, then we might as well do it
> > for the *namespaces* as well ? So ccall them package. And Stanislav,
> > it's not only because java does it that way, it's because python also
> > does, and also because c++ doesn't.
> >
> > After all, why discussing the color of the bikeshed when it's already
> > painted and it's a dogshed ?
> >>
> >> On 17-Aug-07, at 11:06 AM, Richard Quadling wrote:
> >>
> >>> Oh dear. I thought the general feeling was to stick with namespaces?
> >>>
> >>> On 17/08/07, Johannes Schlüter <[EMAIL PROTECTED]> wrote:
> >>>> Hi,
> >>>>
> >>>> I've updated the patch to be compatible with Dmitry's latest
> >>>> changes:
> >>>> http://schlueters.de/~johannes/php/
> >>>> zend_namespace_to_package_20070817.diff
> >>>>
> >>>> johannes
> >>>>
> >>>> On Fri, 2007-08-10 at 11:26 +0200, Johannes Schlüter wrote:
> >>>>> Hi,
> >>>>>
> >>>>> I think we reached the consensus to rename namespaces to packages
> >>>>> as our
> >>>>> implementation is more package-like. Therefore I wrote the
> >>>>> corresponding
> >>>>> patch which tries to get rid of all "namespaces" and "ns" (well,
> >>>>> not all
> >>>>> "ns" only the namespace-related ones of course) used in the code.
> >>>>> Additionally I changed all package-tests. Any objections?
> >>>>>
> >>>>> Does anybody (with the move-on-CVS-server powers) care about the
> >>>>> history
> >>>>> of the tests? Then please cp ZendEngine2/tests/ns_* to pkg_*
> >>>>> there else
> >>>>> I'll do a simple cvs rm and cvs add.
> >>>>>
> >>>>> The patch is at
> >>>>> http://schlueters.de/~johannes/php/zend_namespace_to_package.diff
> >>>>> and
> >>>>> the tarball with the changed tests at
> >>>>> http://schlueters.de/~johannes/php/zend_package_tests.tar.bz2
> >>>>>
> >>>>> johannes
> >>>>>
> >>>>
> >>>> --
> >>>> PHP Internals - PHP Runtime Development Mailing List
> >>>> To unsubscribe, visit: http://www.php.net/unsub.php
> >>>>
> >>>>
> >>>
> >>>
> >>> --
> >>> -----
> >>> Richard Quadling
> >>> Zend Certified Engineer : http://zend.com/zce.php?
> >>> c=ZEND002498&r=213474731
> >>> "Standing on the shoulders of some very clever giants!"
> >>
> >> Ilia Alshanetsky
> >>
> >> --
> >> PHP Internals - PHP Runtime Development Mailing List
> >> To unsubscribe, visit: http://www.php.net/unsub.php
> >>
> >>
> >
> >
> > --
> > David Coallier,
> > Founder & Software Architect,
> > Agora Production (http://agoraproduction.com)
> > 51.42.06.70.18
>
> Ilia Alshanetsky
>
> --
> PHP Internals - PHP Runtime Development Mailing List
> To unsubscribe, visit: http://www.php.net/unsub.php
>
>


-- 
Guilherme Blanco - Web Developer
CBC - Certified Bindows Consultant
Cell Phone: +55 (16) 9166-6902
MSN: [EMAIL PROTECTED]
URL: http://blog.bisna.com
São Carlos - SP/Brazil

Reply via email to