On Tue, Mar 11, 2008 at 4:31 PM, Stanislav Malyshev <[EMAIL PROTECTED]> wrote:

> IMO, better solution would be to have all :: calls change
> called_class, but have also some way to call it without changing
> called_class. Something like your forward_static_call, but I'm not sure
> not using callbacks is a good idea - all caller function use callbacks
> now. Actually, what I'd do would be to generalize forward_static_call
> (which I think also needs better name :) and call_user_func into one
> function (internally) that has parameter which tells if to update or not
> update called_class.
>

I do agree about using a callback with forward_static_call, but one thing
that worries me is that opens the door to really bizzare functionality where
the called_class could wind up being outside of the inheritance chain of the
method being called.

If this could be overcame I think it would be relatively easy to consolidate
this code internally. I will look at it this evening and tomorrow.


> --
> Stanislav Malyshev, Zend Software Architect
> [EMAIL PROTECTED]   http://www.zend.com/
> (408)253-8829   MSN: [EMAIL PROTECTED]
>

Reply via email to