Hello again,

renderSomething(array('exclude' => array('a', 'b', 'c'), 'include' =>
array('d', 'e', 'f')));
vs:
renderSomething(['exclude' => ['a', 'b', 'c'], 'include' => ['d', 'e',
'f']]);

Your version is more readable but try this one:

renderSomething(
        array(
            'exclude' => array('a', 'b', 'c'),
            'include' => array('d', 'e', 'f')
        )
);

Or even break array('a','b','c') and array('d', 'e', 'f') in more lines.
This will become far more readable, with proper names and values.

This is the real life case for me.

Regards, Dimitar

Reply via email to