On Tue, Aug 7, 2018 at 7:48 PM, Tony Battersby <to...@cybernetics.com> wrote:
> To represent the size of a single allocation, dmapool currently uses
> 'unsigned int' in some places and 'size_t' in other places.  Standardize
> on 'unsigned int' to reduce overhead, but use 'size_t' when counting all
> the blocks in the entire pool.

>         else if ((boundary < size) || (boundary & (boundary - 1)))
>                 return NULL;

Just a side note: in above it's is_power_of_2() opencoded.

-- 
With Best Regards,
Andy Shevchenko
_______________________________________________
iommu mailing list
iommu@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/iommu

Reply via email to