Paul Rogers created IMPALA-8033:
-----------------------------------

             Summary: PlanNode getInputCardinality has two conflicting meanings
                 Key: IMPALA-8033
                 URL: https://issues.apache.org/jira/browse/IMPALA-8033
             Project: IMPALA
          Issue Type: Bug
          Components: Frontend
    Affects Versions: Impala 3.1.0
            Reporter: Paul Rogers
            Assignee: Paul Rogers


The use of the method {{PlanNode.getInputCardinality()}} has evolved to have 
two slightly different, but conflicting, meanings:

* The actual cardinality of the input table, needed to compute join cardinality.
* The number of rows to be read, taking into consideration any limits placed on 
reading.

Because join calculations are wrong if we do not use the actual base table 
cardinality, we cannot use the input cardinality interchangeably with table 
cardinality.

Instead, break the function into two: {{getTableCardinality()}} to get the 
actual cardinality for use in joins, and the existing {{getInputCardinality()}} 
used for other purposes.




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to