Abhishek Rawat created IMPALA-15392:
---------------------------------------
Summary: Cap default pool's max memory limit
Key: IMPALA-15392
URL: https://issues.apache.org/jira/browse/IMPALA-15392
Project: IMPALA
Issue Type: Task
Reporter: Abhishek Rawat
The default resource pool currently has an unbounded cluster-wide max memory
limit, which causes concurrent workloads to fail with Out-Of-Memory (OOM)
errors and creates a negative first impression of Impala's concurrency
capabilities. To resolve this, the default request pool should enforce a
maximum memory limit dynamically derived from the total backend memory
available for query execution. This provides a stable, out-of-the-box admission
control experience that safely handles concurrent queries, while still allowing
advanced users to manually tune the admission controller settings for their
specific workloads.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]