[ 
https://issues.apache.org/jira/browse/ARTEMIS-1648?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16356813#comment-16356813
 ] 

Jarek Przygódzki commented on ARTEMIS-1648:
-------------------------------------------

As far as I can tell it's fixed as of 19147e49869d23906baf2cc07d98564043b3b0e0. 
It would be good to know when exactly - ARTEMIS-1644, ARTEMIS-1612 or any 
combination of thereof? Or something else?

> Messages from 1.x clients to 2.x cluster are lost when they are load balanced 
> to nodes with matching consumers
> --------------------------------------------------------------------------------------------------------------
>
>                 Key: ARTEMIS-1648
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1648
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 2.3.0
>            Reporter: Jarek Przygódzki
>            Priority: Major
>
> When a message from 1.x client is transfered to node in the cluster with 
> matching consumers (message-load-balancing=ON_DEMAND), it's moved to 
> appropriate replication queue, forwarded to target node and then subsequently 
> dropped  because there aren't any matching bindings for message address. This 
> is because if the original message is sent to address with the jms.queue 
> prefix (1.x clients), than the message sent by ClusterConnectionBridge also 
> has the prefixed destination address and this situation is not supported.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to