[ 
https://issues.apache.org/jira/browse/ARTEMIS-1731?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16387550#comment-16387550
 ] 

ASF GitHub Bot commented on ARTEMIS-1731:
-----------------------------------------

GitHub user michaelandrepearce opened a pull request:

    https://github.com/apache/activemq-artemis/pull/1933

    ARTEMIS-1731 Support offline validation

    Copy in https://www.w3.org/2005/08/xml.xsd so validation of broker.xml 
works offline.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/michaelandrepearce/activemq-artemis 
ARTEMIS-1731

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/activemq-artemis/pull/1933.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #1933
    
----
commit 055c51d6b1eba2ecdc665138e6545f2c75c67349
Author: Michael André Pearce <michael.andre.pearce@...>
Date:   2018-03-06T09:58:12Z

    ARTEMIS-1731 Support offline validation
    
    Copy in https://www.w3.org/2005/08/xml.xsd so validation of broker.xml 
works offline.

----


> Startup fails when XSD validation cannot access Internet
> --------------------------------------------------------
>
>                 Key: ARTEMIS-1731
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1731
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 2.5.0
>            Reporter: Ilkka Virolainen
>            Priority: Major
>
> After a recent change allowing splitting up the broker configuration across 
> multiple files, starting Artemis fails when the server running broker has no 
> Internet access. xml:specialAttrs references in artemis-configuration.xsd 
> fail because the schema location http://www.w3.org/2005/08/xml.xsd is 
> inaccessible. To reproduce, pull the latest master for 2.5.0-SNAPSHOT, block 
> www.w3.org and try to run a broker. Including the schema in the build would 
> resolve this issue.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to