[ 
https://issues.apache.org/jira/browse/ARTEMIS-1976?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Oleg Sushchenko reopened ARTEMIS-1976:
--------------------------------------

> AMQP IdleTimeout ignoring user defined value
> --------------------------------------------
>
>                 Key: ARTEMIS-1976
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1976
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>            Reporter: Oleg Sushchenko
>            Priority: Major
>
> Steps:
>  * configure broker.xml with amqpIdleTimeout=4000 value:
> {code:java}
> <acceptor 
> name="amqp">tcp://0.0.0.0:5672?amqpIdleTimeout=4000;tcpSendBufferSize=1048576;tcpReceiveBufferSize=1048576;protocols=AMQP;useEpoll=true;amqpCredits=1000;amqpLowCredits=300</acceptor>
>  {code}
>  
>  * start broker
>  * connect to broker with client
>  * check broker logs
> Expected result:
>  * I get Empty Frames every 2 seconds
> Actual results:
>  * Seems that value is not working because I get an Empty Frame every 15 
> seconds
> {code:java}
> 2018-07-10 10:08:29,282 FINE  [proton.trace] IN: CH[0] : Empty Frame
> 2018-07-10 10:08:44,282 FINE  [proton.trace] IN: CH[0] : Empty Frame
> 2018-07-10 10:08:59,282 FINE  [proton.trace] IN: CH[0] : Empty Frame
> 2018-07-10 10:09:14,282 FINE  [proton.trace] IN: CH[0] : Empty Frame
> 2018-07-10 10:09:29,283 FINE  [proton.trace] IN: CH[0] : Empty Frame
> 2018-07-10 10:09:44,282 FINE  [proton.trace] IN: CH[0] : Empty Frame
> 2018-07-10 10:09:59,282 FINE  [proton.trace] IN: CH[0] : Empty Frame
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to