[
https://issues.apache.org/jira/browse/AMQ-8023?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17184158#comment-17184158
]
ASF subversion and git services commented on AMQ-8023:
------------------------------------------------------
Commit 0e2b24be3652eb225fb0a758d373f086000fd72b in activemq's branch
refs/heads/master from gtully
[ https://gitbox.apache.org/repos/asf?p=activemq.git;h=0e2b24b ]
AMQ-8023 - serialize sub add with destination removal advisory processing to
avoid resub blocking a necessary purge via removal, fix and test via mqtt clean
session scenario
> Network bridge shutdown, race on MQTT virtual topic clean session and
> resubscribe
> ---------------------------------------------------------------------------------
>
> Key: AMQ-8023
> URL: https://issues.apache.org/jira/browse/AMQ-8023
> Project: ActiveMQ
> Issue Type: Bug
> Components: MQTT, Network of Brokers
> Affects Versions: 5.16.0
> Reporter: Gary Tully
> Assignee: Gary Tully
> Priority: Major
> Fix For: 5.17.0
>
>
> With MQTT clients using virtual topic subscriptions and clean session. In a
> network of brokers when the remove destination operations are bridged, it is
> possible for the re-subscribe to beat the removeDestination advisory and
> cause the remove to fail with an error, causing the bridge to fail. The
> advisories are in order, but are executed out of order on the remote network
> bridge, in error.
> {code:java}
> WARN | pool-16-thread-1 | Service | ivemq.broker.TransportConnection 304
> | 162 - org.apache.activemq.activemq-osgi | Async error occurred:
> javax.jms.JMSException: Destination still has an active subscription:
> queue://Consumer.340601550021719:AT_LEAST_ONCE.VirtualTopic.IMPORTANT.>
> INFO | Task-310 | DemandForwardingBridgeSupport |
> rk.DemandForwardingBridgeSupport 908 | 162 -
> org.apache.activemq.activemq-osgi | Network connection between vm://AMQ1 and
> ssl:///x.x.x:x shutdown due to a local error: javax.jms.JMSException:
> Destination still has an active subscription:
> queue://Consumer.340601550021719:AT_LEAST_ONCE.VirtualTopic.IMPORTANT.>
> {code}
> Two necessary config options:
> # networkConnector
> destinationFilter="ActiveMQ.Advisory.Consumer.Queue.>,ActiveMQ.Advisory.Queue"
> # &transport.subscriptionStrategy=mqtt-virtual-topic-subscriptions
--
This message was sent by Atlassian Jira
(v8.3.4#803005)