[
https://issues.apache.org/jira/browse/ARTEMIS-4555?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17803738#comment-17803738
]
Justin Bertram commented on ARTEMIS-4555:
-----------------------------------------
This is a well-known danger. In fact, there's a whole chapter in [the
documentation|https://activemq.apache.org/components/artemis/documentation/latest/network-isolation.html#network-isolation-split-brain]
about it. You should deploy at least 3 HA pairs to establish a proper quorum
for voting and set
{{<vote-on-replication-failure>true</vote-on-replication-failure>}} on the
backup. The next release will have better documentation around both the high
level explanation and the low-level configuration for split-brain scenarios.
> ActiveMq Artemis can have two live brokers in one cluster at one time
> ---------------------------------------------------------------------
>
> Key: ARTEMIS-4555
> URL: https://issues.apache.org/jira/browse/ARTEMIS-4555
> Project: ActiveMQ Artemis
> Issue Type: Bug
> Components: Broker, Clustering
> Affects Versions: 2.30.0
> Reporter: Sophia
> Priority: Major
>
> An ActiveMq Artemis cluster can have two live brokers that can receive
> requests at the same time. This happens if the communication drops between
> the live broker and the passive broker.
>
> We deploy ActiveMQ Artemis v(2.30.0) on a five nodes cluster with Ubuntu
> 18.04. The cluster consists of a master broker and three backup brokers. We
> deploy classic replication with three backups for the master broker. One of
> the backup brokers announces its status as a passive backup for the live
> broker.
>
> If the communication breaks between the live and the passive broker, the
> passive broker changes its status to live and starts accepting messages. A
> warning message appears on all nodes telling that there are two live brokers
> in the cluster. When we fix the network problem, the cluster still has two
> live brokers that can accept requests. Although we set allow-fail-back to
> true on the backups config which should force the backup that has become live
> to automatically stop when the live is back.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)