[ 
https://issues.apache.org/jira/browse/AMBARI-18577?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15586430#comment-15586430
 ] 

Hadoop QA commented on AMBARI-18577:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest 
attachment 
  
http://issues.apache.org/jira/secure/attachment/12833927/0001-AMBARI-18577-add-non-interactive-flag-to-zypper-comm.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author 
tags.

    {color:red}-1 tests included{color}.  The patch doesn't appear to include 
any new or modified tests.
                        Please justify why no new tests are needed for this 
patch.
                        Also please list what manual steps were performed to 
verify this patch.

    {color:green}+1 javac{color}.  The applied patch does not increase the 
total number of javac compiler warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase 
the total number of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in 
ambari-server.

Test results: 
https://builds.apache.org/job/Ambari-trunk-test-patch/8909//testReport/
Console output: 
https://builds.apache.org/job/Ambari-trunk-test-patch/8909//console

This message is automatically generated.

> Installing ambari agent on Suse fails, when zypper has questions
> ----------------------------------------------------------------
>
>                 Key: AMBARI-18577
>                 URL: https://issues.apache.org/jira/browse/AMBARI-18577
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.4.0
>         Environment: Suse 11p3
>            Reporter: Zsombor Gegesy
>             Fix For: trunk
>
>         Attachments: 
> 0001-AMBARI-18577-add-non-interactive-flag-to-zypper-comm.patch
>
>
> During installing the ambari-agent on hosts, the process stuck at :
> {noformat}
> 17829 pts/0    Ss+    0:00  |   \_ /bin/bash 
> /var/lib/ambari-agent/tmp/ambari-sudo.sh python 
> /var/lib/ambari-agent/tmp/setupAgent1476267067.py 
> os-sles11-3-cluster-3.openstacklocal DEV os-sles11
> 17855 pts/0    S+     0:00  |       \_ python 
> /var/lib/ambari-agent/tmp/setupAgent1476267067.py 
> os-sles11-3-cluster-3.openstacklocal DEV os-sles11-3-cluster.openstacklocal 
> root 2.4
> 18357 pts/0    S+     0:00  |           \_ bash -c zypper --no-gpg-checks -q 
> search -s --match-exact ambari-agent | grep ambari-agent | sed -re 's/\s+/ 
> /g' | cut -d '|' -f 4 | tr '\n' ', ' | sed -s 's/[-|
> 18358 pts/0    S+     0:00  |               \_ zypper --no-gpg-checks -q 
> search -s --match-exact ambari-agent
> 18359 pts/0    S+     0:00  |               \_ grep ambari-agent
> 18360 pts/0    S+     0:00  |               \_ sed -re s/\s+/ /g
> 18361 pts/0    S+     0:00  |               \_ cut -d | -f 4
> 18362 pts/0    S+     0:00  |               \_ tr \n , 
> 18363 pts/0    S+     0:00  |               \_ sed -s s/[-|~][A-Za-z0-9]*//g
> {noformat}
> Unfortunately the process hangs there forever, other zypper processes refuses 
> to do anything. After killing the processes, it is possible to use the system 
> again, and check what happened. It seems, that zypper has a problem with one 
> of the repository from Suse :
> {noformat}
> File '/repodata/repomd.xml' not found on medium 
> 'http://download.opensuse.org/repositories/Cloud:/Tools/SLE_11_SP3/'
> Abort, retry, ignore? [a/r/i/?] (a):
> {noformat}
> This problem can be solved, with adding the --non-interactive flag



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to