[ 
https://issues.apache.org/jira/browse/AMBARI-19060?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Swapan Shridhar updated AMBARI-19060:
-------------------------------------
    Attachment: AMBARI-19060.patch

> Update the HiveServer config values if Security Authorization chosen is None.
> -----------------------------------------------------------------------------
>
>                 Key: AMBARI-19060
>                 URL: https://issues.apache.org/jira/browse/AMBARI-19060
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.4.1
>            Reporter: Swapan Shridhar
>            Assignee: Swapan Shridhar
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-19060.patch
>
>
> - When hive-env/hive_security_authorization chosen value is None.
> - Following configs should be set as: 
>   *"hive.server2.enable.doAs"* = "true"
>   *"hive.security.authorization.enabled"* = "false", and
> - Following configs should be deleted
>    *"hive.security.authorization.manager"*
>    *"hive.security.authenticator.manager"*
>    *"hive.conf.restricted.list"*
> Also, if *hive-env/hive_security_authorization* is selected as *'sqlstdauth'* 
> or *'ranger'*, the following configs should be set as:
> - "hive.conf.restricted.list" = 
> "hive.security.authenticator.manager,hive.security.authorization.manager,hive.security.metastore.authorization.manager,
>  
> hive.security.metastore.authenticator.manager,hive.users.in.admin.role,hive.server2.xsrf.filter.enabled,hive.security.authorization.enabled"



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to