[ 
https://issues.apache.org/jira/browse/AMBARI-21685?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16118990#comment-16118990
 ] 

Andrew Onischuk commented on AMBARI-21685:
------------------------------------------

+1

> Component fails to install with error, "The stack packages are not defined on 
> the command. Unable to load packages for the stack-select tool"
> ---------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-21685
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21685
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>            Reporter: Kishor Ramakrishnan
>            Assignee: Alejandro Fernandez
>             Fix For: 3.0.0
>
>         Attachments: AMBARI-21685.patch
>
>
> STR:
> * Install Ambari 3.0 build 1020
> * Install HDP 3.0
> {code}
> Traceback (most recent call last):
>   File 
> "/var/lib/ambari-agent/cache/stacks/HDP/3.0/hooks/before-INSTALL/scripts/hook.py",
>  line 37, in <module>
>     BeforeInstallHook().execute()
>   File 
> "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
>  line 336, in execute
>     self.save_component_version_to_structured_out()
>   File 
> "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
>  line 218, in save_component_version_to_structured_out
>     stack_select_package_name = stack_select.get_package_name()
>   File 
> "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/stack_select.py",
>  line 98, in get_package_name
>     package = get_packages(PACKAGE_SCOPE_STACK_SELECT, service_name, 
> component_name)
>   File 
> "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/stack_select.py",
>  line 143, in get_packages
>     raise Fail("The stack packages are not defined on the command. Unable to 
> load packages for the stack-select tool")
> resource_management.core.exceptions.Fail: The stack packages are not defined 
> on the command. Unable to load packages for the stack-select tool
> Traceback (most recent call last):
>   File 
> "/var/lib/ambari-agent/cache/stacks/HDP/3.0/hooks/before-INSTALL/scripts/hook.py",
>  line 37, in <module>
>     BeforeInstallHook().execute()
>   File 
> "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
>  line 336, in execute
>     self.save_component_version_to_structured_out()
>   File 
> "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
>  line 218, in save_component_version_to_structured_out
>     stack_select_package_name = stack_select.get_package_name()
>   File 
> "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/stack_select.py",
>  line 98, in get_package_name
>     package = get_packages(PACKAGE_SCOPE_STACK_SELECT, service_name, 
> component_name)
>   File 
> "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/stack_select.py",
>  line 143, in get_packages
>     raise Fail("The stack packages are not defined on the command. Unable to 
> load packages for the stack-select tool")
> resource_management.core.exceptions.Fail: The stack packages are not defined 
> on the command. Unable to load packages for the stack-select tool
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to