[ 
https://issues.apache.org/jira/browse/AMBARI-22937?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Robert Levas updated AMBARI-22937:
----------------------------------
    Description: 
Deactivate unsupported stack definitions in Ambari.  This includes HDP versions 
before 2.6.

{noformat:title=Active Stacks}
./3.0/metainfo.xml:    <active>true</active>
./2.6/metainfo.xml:    <active>true</active>
./2.5/metainfo.xml:    <active>true</active>
./2.4/metainfo.xml:    <active>true</active>
./2.3/metainfo.xml:    <active>true</active>
{noformat}

There is no enforcement of minimum stack level during the upgrade process. The 
user is expected to have performed the necessary actions to meet the 
_documented_ minimum stack level. 



  was:
Remove stack definitions for HDP versions below 2.6.

This includes orphaned definitions from the stacks and common-services 
directories.

There is no enforcement of minimum stack level during the upgrade process. The 
user is expected to have performed the necessary actions to meet the 
_documented_ minimum stack level.


> Deactivate unsupported stack definitions in Ambari
> --------------------------------------------------
>
>                 Key: AMBARI-22937
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22937
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-server
>    Affects Versions: 2.7.0
>            Reporter: Robert Levas
>            Assignee: Robert Levas
>            Priority: Major
>             Fix For: 2.7.0
>
>
> Deactivate unsupported stack definitions in Ambari.  This includes HDP 
> versions before 2.6.
> {noformat:title=Active Stacks}
> ./3.0/metainfo.xml:    <active>true</active>
> ./2.6/metainfo.xml:    <active>true</active>
> ./2.5/metainfo.xml:    <active>true</active>
> ./2.4/metainfo.xml:    <active>true</active>
> ./2.3/metainfo.xml:    <active>true</active>
> {noformat}
> There is no enforcement of minimum stack level during the upgrade process. 
> The user is expected to have performed the necessary actions to meet the 
> _documented_ minimum stack level. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to