[ 
https://issues.apache.org/jira/browse/AMBARI-23143?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Dmitry Lysnichenko updated AMBARI-23143:
----------------------------------------
    Description: 
Test steps :
1) Deploy a cluster with ambari-2.5.1.0-159 + HDP-2.6.1.0-129
2) Upgrade ambari to 2.6.2.0-82
3) Now try to restart all the services. The operation is failing with below 
exception while trying to start Spark2
{code:java}
Traceback (most recent call last):
  File 
"/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/hook.py",
 line 37, in <module>
    AfterInstallHook().execute()
  File 
"/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", 
line 375, in execute
    method(env)
  File 
"/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/hook.py",
 line 31, in hook
    setup_stack_symlinks(self.stroutfile)
  File 
"/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/shared_initialization.py",
 line 49, in setup_stack_symlinks
    stack_packages = 
stack_select.get_packages(stack_select.PACKAGE_SCOPE_INSTALL)
  File 
"/usr/lib/ambari-agent/lib/resource_management/libraries/functions/stack_select.py",
 line 235, in get_packages
    raise Fail("The package {0} is not supported by this version of the 
stack-select tool.".format(package))
resource_management.core.exceptions.Fail: The package livy2-client is not 
supported by this version of the stack-select tool.{code}
livy2-client package was added in HDP 2.6.3 and was not present before that.

  was:
Test steps :
1) Deploy a cluster with ambari-2.5.1.0-159 + HDP-2.6.1.0-129
2) Upgrade ambari to 2.6.2.0-82
3) Now try to restart all the services. The operation is failing with below 
exception while trying to start Spark2
{code:java}
Traceback (most recent call last):
  File 
"/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/hook.py",
 line 37, in <module>
    AfterInstallHook().execute()
  File 
"/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", 
line 375, in execute
    method(env)
  File 
"/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/hook.py",
 line 31, in hook
    setup_stack_symlinks(self.stroutfile)
  File 
"/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/shared_initialization.py",
 line 49, in setup_stack_symlinks
    stack_packages = 
stack_select.get_packages(stack_select.PACKAGE_SCOPE_INSTALL)
  File 
"/usr/lib/ambari-agent/lib/resource_management/libraries/functions/stack_select.py",
 line 235, in get_packages
    raise Fail("The package {0} is not supported by this version of the 
stack-select tool.".format(package))
resource_management.core.exceptions.Fail: The package livy2-client is not 
supported by this version of the stack-select tool.{code}


> Failure while starting Spark2 service after performing ambari upgrade
> ---------------------------------------------------------------------
>
>                 Key: AMBARI-23143
>                 URL: https://issues.apache.org/jira/browse/AMBARI-23143
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.6.2
>         Environment: ambari-server --version 2.6.2.0-82
> HDP-2.6.1.0-129
>            Reporter: Supreeth Sharma
>            Assignee: Dmitry Lysnichenko
>            Priority: Blocker
>             Fix For: 2.6.2
>
>
> Test steps :
> 1) Deploy a cluster with ambari-2.5.1.0-159 + HDP-2.6.1.0-129
> 2) Upgrade ambari to 2.6.2.0-82
> 3) Now try to restart all the services. The operation is failing with below 
> exception while trying to start Spark2
> {code:java}
> Traceback (most recent call last):
>   File 
> "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/hook.py",
>  line 37, in <module>
>     AfterInstallHook().execute()
>   File 
> "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", 
> line 375, in execute
>     method(env)
>   File 
> "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/hook.py",
>  line 31, in hook
>     setup_stack_symlinks(self.stroutfile)
>   File 
> "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/after-INSTALL/scripts/shared_initialization.py",
>  line 49, in setup_stack_symlinks
>     stack_packages = 
> stack_select.get_packages(stack_select.PACKAGE_SCOPE_INSTALL)
>   File 
> "/usr/lib/ambari-agent/lib/resource_management/libraries/functions/stack_select.py",
>  line 235, in get_packages
>     raise Fail("The package {0} is not supported by this version of the 
> stack-select tool.".format(package))
> resource_management.core.exceptions.Fail: The package livy2-client is not 
> supported by this version of the stack-select tool.{code}
> livy2-client package was added in HDP 2.6.3 and was not present before that.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to