Tamas Payer created AMBARI-25496:
------------------------------------

             Summary: Upgrade pre-check fails when attempting to upgrade from 
HDP 2.6 to 7.1 on ubuntu18 
                 Key: AMBARI-25496
                 URL: https://issues.apache.org/jira/browse/AMBARI-25496
             Project: Ambari
          Issue Type: Bug
          Components: ambari-sever
    Affects Versions: 2.6.2
         Environment: ubuntu18
            Reporter: Tamas Payer
            Assignee: Tamas Payer
             Fix For: 2.7.6


When trying to Express Upgrade from HDP 2.6.5 to the latest version on ubuntu18 
 the upgrade pre checks failed.

When we hit below api:
[http://example.com:8080/api/v1/clusters/cl1/rolling_upgrades_check?fields=*&UpgradeChecks/repository_version_id=51&UpgradeChecks/upgrade_type=NON_ROLLING|http://172.27.30.73:8080/api/v1/clusters/cl1/rolling_upgrades_check?fields=*&UpgradeChecks/repository_version_id=51&UpgradeChecks/upgrade_type=NON_ROLLING]
{code:java}
{
      "href" : 
"http://172.27.30.73:8080/api/v1/clusters/cl1/rolling_upgrades_check/MISSING_OS_IN_REPO_VERSION";,
      "UpgradeChecks" : {
        "check" : "Missing OS in repository version.",
        "check_type" : "CLUSTER",
        "cluster_name" : "cl1",
        "failed_detail" : [ ],
        "failed_on" : [
          "ubuntu18"
        ],
        "id" : "MISSING_OS_IN_REPO_VERSION",
        "reason" : "The source version must have an entry for each OS type in 
the cluster",
        "repository_version_id" : 51,
        "status" : "FAIL",
        "upgrade_type" : "NON_ROLLING"
      }
    }
{code}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to