[ 
https://issues.apache.org/jira/browse/AMBARI-5463?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17090392#comment-17090392
 ] 

Dmytro Grinenko commented on AMBARI-5463:
-----------------------------------------

closing this in favor of AMBARI-25504, which is more generalized - EOL of 
python 2. 

> Upgradings for Python3 and Ubuntu supporting
> --------------------------------------------
>
>                 Key: AMBARI-5463
>                 URL: https://issues.apache.org/jira/browse/AMBARI-5463
>             Project: Ambari
>          Issue Type: Improvement
>          Components: ambari-agent, ambari-server, ambari-web, contrib, infra, 
> site
>    Affects Versions: 1.6.1
>         Environment: ubuntu
>            Reporter: simonzhang
>            Assignee: Simon Zhang
>            Priority: Major
>              Labels: patch
>   Original Estimate: 612h
>  Remaining Estimate: 612h
>
> 1. Apply 2to3 -w files to transfer python 2 into python 3 automatically
> 2. Manually update some files into python 3, such as unicode encoding from 
> binary to unicode, str.object and bytes.object use .encode() (str -> bytes) 
> or .decode() (bytes -> str)
> 3. SyntaxError updates, such as .xml errors.
> 4. Updates for ubuntu supportings



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to