[ 
https://issues.apache.org/jira/browse/AMBARI-25519?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17133811#comment-17133811
 ] 

Steven Matison edited comment on AMBARI-25519 at 6/12/20, 12:28 AM:
--------------------------------------------------------------------

Edit bower.json with suitable combinations of angular and angular-plugins.  
edit pom.xml with suitable versions for node/npm.   

Below is an example I was able to resolve today.

{{nodeVersion: v10.21.0}}

{{npmVersion: 6.14.4}}
{code:java}
{
  "name": "adminconsole",
  "private": true,
  "dependencies": {
    "bootstrap": "3.3.7",
    "angular": "1.3.0",
    "angular-route": "1.3.0",
    "angular-bootstrap": "0.11.0",
    "underscore": "1.7.0",
    "restangular": "1.4.0",
    "angular-bootstrap-toggle-switch": "0.5.1",
    "angular-animate": "1.3.0",
    "angular-translate": "~2.8.1",
    "font-awesome": "4.2.0"
  },
  "devDependencies": {
    "angular-mocks": "1.3.0",
    "commonjs": "0.2.0",
    "chai": "1.8.0",
    "mocha": "1.14.0",
    "sinon": "1.10.3"
  }
} {code}
{{}}


was (Author: stevendfheinz):
Edit bower.json with suitable combinations of angular and angular-plugins.  
edit pom.xml with suitable versions for node/npm.   

Below is an example I was able to resolve today.

{{nodeVersion: v10.21.0}}

{{npmVersion: 6.14.4}}
{code:java}
{
  "name": "adminconsole",
  "private": true,
  "dependencies": {
    "bootstrap": "3.3.7",
    "angular": "1.3.0",
    "angular-route": "1.3.0",
    "angular-bootstrap": "0.11.0",
    "underscore": "1.7.0",
    "restangular": "1.4.0",
    "angular-bootstrap-toggle-switch": "0.5.1",
    "angular-animate": "1.3.0",
    "angular-translate": "~2.8.1",
    "font-awesome": "4.2.0"
  },
  "devDependencies": {
    "angular-mocks": "1.3.0",
    "commonjs": "0.2.0",
    "chai": "1.8.0",
    "mocha": "1.14.0",
    "sinon": "1.10.3"
  }
}{code}
 

{{}}

> Ambari builds are failing with a bower error
> --------------------------------------------
>
>                 Key: AMBARI-25519
>                 URL: https://issues.apache.org/jira/browse/AMBARI-25519
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-admin
>    Affects Versions: 2.7.4, 2.7.5
>            Reporter: Dmytro Pidhaiets
>            Assignee: Dmytro Grinenko
>            Priority: Major
>             Fix For: 2.7.6
>
>          Time Spent: 1h
>  Remaining Estimate: 0h
>
> {code}
> 2020/06/05 12:34:51 - util.py::run_cmd          343 - INFO    : bower 
> angular#>=1.2.26 <1.8                         download 
> https://github.com/angular/bower-angular/archive/v1.7.9.tar.gz2020/06/05 
> 12:34:51 - util.py::run_cmd          343 - INFO    : bower angular#>=1.2.26 
> <1.8                          extract archive.tar.gz
> 2020/06/05 12:34:51 - util.py::run_cmd          343 - INFO    : bower 
> angular#>=1.2.26 <1.8                         resolved 
> https://github.com/angular/bower-angular.git#1.7.92020/06/05 12:34:51 - 
> util.py::run_cmd          343 - INFO    : bower                               
>                ECONFLICT Unable to find suitable version for angular
> {code}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to