[ 
https://issues.apache.org/jira/browse/MRM-1929?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Wojtek updated MRM-1929:
------------------------
    Description: 
I've managed to setup repository and it works just fine - files are removed 
from the drive, however - index is not updated which results in those artifacts 
being listed in the "artifacts" tab and 404 ("Resource does not exist") errors 
while trying to download them.

Manually executing Directory or Index Scanning (and selecting "Process All 
Artifacts") doesn't do anything - artifacts are still listed.

Acessing repo through WebDav display correct list.

I know there are a couple of related issues (for example MRM-544) related but 
all of them are marked as fixed

  was:
I've managed to setup repository and it works just fine - files are removed 
from the drive, however - index is not updated which results in those artifacts 
being listed in the "artifacts" tab and 404 ("Resource does not exist") errors 
while trying to download them.

Manually executing Directory or Index Scanning (and selecting "Process All 
Artifacts") doesn't do anything - artifacts are still listed.

Acessing repo through WebDav display correct list.


> Repository purge is not reflected in index
> ------------------------------------------
>
>                 Key: MRM-1929
>                 URL: https://issues.apache.org/jira/browse/MRM-1929
>             Project: Archiva
>          Issue Type: Bug
>    Affects Versions: 2.2.1
>         Environment: Ubuntu LTS, complete-standalone Archiva binary 
>            Reporter: Wojtek
>
> I've managed to setup repository and it works just fine - files are removed 
> from the drive, however - index is not updated which results in those 
> artifacts being listed in the "artifacts" tab and 404 ("Resource does not 
> exist") errors while trying to download them.
> Manually executing Directory or Index Scanning (and selecting "Process All 
> Artifacts") doesn't do anything - artifacts are still listed.
> Acessing repo through WebDav display correct list.
> I know there are a couple of related issues (for example MRM-544) related but 
> all of them are marked as fixed



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to