[ 
https://issues.apache.org/jira/browse/ARROW-1337?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16119187#comment-16119187
 ] 

Leo commented on ARROW-1337:
----------------------------

Hi [~wesmckinn],

I'm building Arrow and pyarrow 0.5.0 using Guix, which means that each build 
takes place in a minimal chroot.

First, I build Arrow with these flags:

{code}
-DCMAKE_BUILD_TYPE=Release
-DARROW_PYTHON=ON
-DARROW_BUILD_TESTS=OFF
-DARROW_BUILD_STATIC=OFF
-DCMAKE_INSTALL_LIBDIR=/gnu/store/...longhash...-arrow-0.5.0/lib
{code}
... plus a few other flags related to optional dependencies.

Then, I build pyarrow in a second, separate build. In this environment, the 
built Arrow is made accessible. Based on some instructions I had found 
(unfortunately I cannot recall which), I tried including pkg-config in this 
build to help pyarrow find its dependencies. However, this led to the error 
message that is the subject of this bug report.

When I instead made ARROW_HOME point to the location of the compiled Arrow, 
pyarrow built successfully.

Below is the environment in the chroot where pyarrow failed to build:
{code}
export 
BASH_LOADABLES_PATH="/gnu/store/k7029k5va68lkapbzcycdzj7m5bjb4b8-bash-4.4.12/lib/bash"
export 
CMAKE_PREFIX_PATH="/gnu/store/bf54hnwd8mb63zmssc23fwslf5zvxpxs-python-wrapper-3.5.3/:/gnu/store/fxd2ryc7vam42af3k50xzhcl179zj6ac-python-cython-0.25.2/:/gnu/store/2xyagz0rvhhhg4qgpqc9vsbxls6wlmx1-cmake-3.7.2/:/gnu/store/2xm70k2vppjw5m4aqnh9ii3hiz667dg2-pkg-config-0.29.1/:/gnu/store/37vxs78h32r7z4h0q42q1sd9jkf0dssj-python-pytest-2.7.3/:/gnu/store/g2djv18c2qgaj2law3rg5201w5s374mr-python-setuptools-scm-1.15.0/:/gnu/store/kzrvjk4j8mjcbvnl8jml42f1h8d5q655-git-checkout/:/gnu/store/h3cb0ynq76cmzs2vp2syqd42kkdh9paa-apache-arrow-0.5.0/:/gnu/store/p3rakgmppp6gcb8309x0gz620bwspjny-python-six-1.10.0/:/gnu/store/105aqvn7cizpml0ijq54zhhl27992pr2-python-numpy-1.12.0/:/gnu/store/kyv5jhhn2d9p7vvkzijhr5jj3s84i4qj-python-pandas-0.19.2/:/gnu/store/mfx9ib0cy6mvjfmszplnlh0dvdb0513v-tar-1.29/:/gnu/store/8wmanahsh0mk1n5xw6i7wpwih95yqzaq-gzip-1.8/:/gnu/store/8nkj1w5whm5gwrhsmqvm1w6im27vz02g-bzip2-1.0.6/:/gnu/store/c140q16b1n4x0j2i7wv1awc1c39ipzrr-xz-5.2.2/:/gnu/store/0xm7szwymsv87z7y4bi2lgvx2jhniqms-file-5.28/:/gnu/store/kbs0012il9z63kp0nlq0h66m6zjp4f21-diffutils-3.5/:/gnu/store/qbngj80kmydl4jsba2cdgwq2y51xlfv0-patch-2.7.5/:/gnu/store/z763jk8lkragpz2qr2wbrz946lgalx2h-sed-4.4/:/gnu/store/gdgrzf1y15scqwk1yzm51dc40g29vad9-findutils-4.6.0/:/gnu/store/55r4yg5iw9zh2j3zvzc6272k5xn4yxg4-gawk-4.1.4/:/gnu/store/87sj03j9kwzhl9zr76gs2i8ill86ki95-grep-3.0/:/gnu/store/6908gy3pws0ccys49ni98idwnicchlr2-coreutils-8.26/:/gnu/store/alg6ani0nnwrxyz15d1j5d0k6qs2m5sk-make-4.2.1/:/gnu/store/k7029k5va68lkapbzcycdzj7m5bjb4b8-bash-4.4.12/:/gnu/store/ri56wnmzkgzrajdyl5ydc55lrwy1164k-ld-wrapper-0/:/gnu/store/zq65kpvwwxgc3qqbf9apic8gyss2l0zq-binutils-2.27/:/gnu/store/4iw4r2majarqlm19adaikqw126jxqf2p-gcc-5.4.0/:/gnu/store/rmjlycdgiq8pfy5hfi42qhw3k7p6kdav-glibc-2.25/:/gnu/store/1h0p1lgl5i1dmwa0rzxflv664zwwm6am-glibc-utf8-locales-2.25/:/gnu/store/3aw9x28la9nh8fzkm665d7fywxzbl15j-python-3.5.3/:/gnu/store/s7n625jx3zd4ia2sabfc4kxwzkgx9n17-python-py-1.4.32/:/gnu/store/zfvaglpfb5x3659gi2pqxq7mar5jg4is-python-dateutil-2.6.0/:/gnu/store/zkbdxzygyyn0fqrlsn6szbicf66cxzr0-python-pytz-2017.2/:/gnu/store/5bh7p754d09wcp64ckxlvwz7lgyk0h59-linux-libre-headers-4.4.47/"
export 
CPLUS_INCLUDE_PATH="/gnu/store/h3cb0ynq76cmzs2vp2syqd42kkdh9paa-apache-arrow-0.5.0/include:/gnu/store/8nkj1w5whm5gwrhsmqvm1w6im27vz02g-bzip2-1.0.6/include:/gnu/store/c140q16b1n4x0j2i7wv1awc1c39ipzrr-xz-5.2.2/include:/gnu/store/0xm7szwymsv87z7y4bi2lgvx2jhniqms-file-5.28/include:/gnu/store/55r4yg5iw9zh2j3zvzc6272k5xn4yxg4-gawk-4.1.4/include:/gnu/store/alg6ani0nnwrxyz15d1j5d0k6qs2m5sk-make-4.2.1/include:/gnu/store/zq65kpvwwxgc3qqbf9apic8gyss2l0zq-binutils-2.27/include:/gnu/store/4iw4r2majarqlm19adaikqw126jxqf2p-gcc-5.4.0/include:/gnu/store/rmjlycdgiq8pfy5hfi42qhw3k7p6kdav-glibc-2.25/include:/gnu/store/3aw9x28la9nh8fzkm665d7fywxzbl15j-python-3.5.3/include:/gnu/store/5bh7p754d09wcp64ckxlvwz7lgyk0h59-linux-libre-headers-4.4.47/include"
export 
C_INCLUDE_PATH="/gnu/store/h3cb0ynq76cmzs2vp2syqd42kkdh9paa-apache-arrow-0.5.0/include:/gnu/store/8nkj1w5whm5gwrhsmqvm1w6im27vz02g-bzip2-1.0.6/include:/gnu/store/c140q16b1n4x0j2i7wv1awc1c39ipzrr-xz-5.2.2/include:/gnu/store/0xm7szwymsv87z7y4bi2lgvx2jhniqms-file-5.28/include:/gnu/store/55r4yg5iw9zh2j3zvzc6272k5xn4yxg4-gawk-4.1.4/include:/gnu/store/alg6ani0nnwrxyz15d1j5d0k6qs2m5sk-make-4.2.1/include:/gnu/store/zq65kpvwwxgc3qqbf9apic8gyss2l0zq-binutils-2.27/include:/gnu/store/4iw4r2majarqlm19adaikqw126jxqf2p-gcc-5.4.0/include:/gnu/store/rmjlycdgiq8pfy5hfi42qhw3k7p6kdav-glibc-2.25/include:/gnu/store/3aw9x28la9nh8fzkm665d7fywxzbl15j-python-3.5.3/include:/gnu/store/5bh7p754d09wcp64ckxlvwz7lgyk0h59-linux-libre-headers-4.4.47/include"
export 
GUIX_LOCPATH="/gnu/store/1h0p1lgl5i1dmwa0rzxflv664zwwm6am-glibc-utf8-locales-2.25/lib/locale"
export HOME="/homeless-shelter"
export LC_ALL="en_US.utf8"
export 
LIBRARY_PATH="/gnu/store/fxd2ryc7vam42af3k50xzhcl179zj6ac-python-cython-0.25.2/lib:/gnu/store/37vxs78h32r7z4h0q42q1sd9jkf0dssj-python-pytest-2.7.3/lib:/gnu/store/g2djv18c2qgaj2law3rg5201w5s374mr-python-setuptools-scm-1.15.0/lib:/gnu/store/h3cb0ynq76cmzs2vp2syqd42kkdh9paa-apache-arrow-0.5.0/lib:/gnu/store/p3rakgmppp6gcb8309x0gz620bwspjny-python-six-1.10.0/lib:/gnu/store/105aqvn7cizpml0ijq54zhhl27992pr2-python-numpy-1.12.0/lib:/gnu/store/kyv5jhhn2d9p7vvkzijhr5jj3s84i4qj-python-pandas-0.19.2/lib:/gnu/store/8nkj1w5whm5gwrhsmqvm1w6im27vz02g-bzip2-1.0.6/lib:/gnu/store/c140q16b1n4x0j2i7wv1awc1c39ipzrr-xz-5.2.2/lib:/gnu/store/0xm7szwymsv87z7y4bi2lgvx2jhniqms-file-5.28/lib:/gnu/store/55r4yg5iw9zh2j3zvzc6272k5xn4yxg4-gawk-4.1.4/lib:/gnu/store/k7029k5va68lkapbzcycdzj7m5bjb4b8-bash-4.4.12/lib:/gnu/store/zq65kpvwwxgc3qqbf9apic8gyss2l0zq-binutils-2.27/lib:/gnu/store/rmjlycdgiq8pfy5hfi42qhw3k7p6kdav-glibc-2.25/lib:/gnu/store/1h0p1lgl5i1dmwa0rzxflv664zwwm6am-glibc-utf8-locales-2.25/lib:/gnu/store/3aw9x28la9nh8fzkm665d7fywxzbl15j-python-3.5.3/lib:/gnu/store/s7n625jx3zd4ia2sabfc4kxwzkgx9n17-python-py-1.4.32/lib:/gnu/store/zfvaglpfb5x3659gi2pqxq7mar5jg4is-python-dateutil-2.6.0/lib:/gnu/store/zkbdxzygyyn0fqrlsn6szbicf66cxzr0-python-pytz-2017.2/lib"
export NIX_BUILD_CORES="0"
export NIX_BUILD_TOP="/tmp/guix-build-python-pyarrow-0.5.0.drv-0"
export NIX_STORE="/gnu/store"
export OLDPWD
export 
PATH="/gnu/store/bf54hnwd8mb63zmssc23fwslf5zvxpxs-python-wrapper-3.5.3/bin:/gnu/store/fxd2ryc7vam42af3k50xzhcl179zj6ac-python-cython-0.25.2/bin:/gnu/store/2xyagz0rvhhhg4qgpqc9vsbxls6wlmx1-cmake-3.7.2/bin:/gnu/store/2xm70k2vppjw5m4aqnh9ii3hiz667dg2-pkg-config-0.29.1/bin:/gnu/store/37vxs78h32r7z4h0q42q1sd9jkf0dssj-python-pytest-2.7.3/bin:/gnu/store/105aqvn7cizpml0ijq54zhhl27992pr2-python-numpy-1.12.0/bin:/gnu/store/mfx9ib0cy6mvjfmszplnlh0dvdb0513v-tar-1.29/bin:/gnu/store/8wmanahsh0mk1n5xw6i7wpwih95yqzaq-gzip-1.8/bin:/gnu/store/8nkj1w5whm5gwrhsmqvm1w6im27vz02g-bzip2-1.0.6/bin:/gnu/store/c140q16b1n4x0j2i7wv1awc1c39ipzrr-xz-5.2.2/bin:/gnu/store/0xm7szwymsv87z7y4bi2lgvx2jhniqms-file-5.28/bin:/gnu/store/kbs0012il9z63kp0nlq0h66m6zjp4f21-diffutils-3.5/bin:/gnu/store/qbngj80kmydl4jsba2cdgwq2y51xlfv0-patch-2.7.5/bin:/gnu/store/z763jk8lkragpz2qr2wbrz946lgalx2h-sed-4.4/bin:/gnu/store/gdgrzf1y15scqwk1yzm51dc40g29vad9-findutils-4.6.0/bin:/gnu/store/55r4yg5iw9zh2j3zvzc6272k5xn4yxg4-gawk-4.1.4/bin:/gnu/store/87sj03j9kwzhl9zr76gs2i8ill86ki95-grep-3.0/bin:/gnu/store/6908gy3pws0ccys49ni98idwnicchlr2-coreutils-8.26/bin:/gnu/store/alg6ani0nnwrxyz15d1j5d0k6qs2m5sk-make-4.2.1/bin:/gnu/store/k7029k5va68lkapbzcycdzj7m5bjb4b8-bash-4.4.12/bin:/gnu/store/ri56wnmzkgzrajdyl5ydc55lrwy1164k-ld-wrapper-0/bin:/gnu/store/zq65kpvwwxgc3qqbf9apic8gyss2l0zq-binutils-2.27/bin:/gnu/store/4iw4r2majarqlm19adaikqw126jxqf2p-gcc-5.4.0/bin:/gnu/store/rmjlycdgiq8pfy5hfi42qhw3k7p6kdav-glibc-2.25/bin:/gnu/store/rmjlycdgiq8pfy5hfi42qhw3k7p6kdav-glibc-2.25/sbin:/gnu/store/3aw9x28la9nh8fzkm665d7fywxzbl15j-python-3.5.3/bin"
export 
PKG_CONFIG_PATH="/gnu/store/h3cb0ynq76cmzs2vp2syqd42kkdh9paa-apache-arrow-0.5.0/lib/pkgconfig:/gnu/store/c140q16b1n4x0j2i7wv1awc1c39ipzrr-xz-5.2.2/lib/pkgconfig:/gnu/store/3aw9x28la9nh8fzkm665d7fywxzbl15j-python-3.5.3/lib/pkgconfig"
export PWD="/tmp/guix-build-python-pyarrow-0.5.0.drv-0/source/python"
export 
PYTHONPATH="/gnu/store/fxd2ryc7vam42af3k50xzhcl179zj6ac-python-cython-0.25.2/lib/python3.5/site-packages:/gnu/store/37vxs78h32r7z4h0q42q1sd9jkf0dssj-python-pytest-2.7.3/lib/python3.5/site-packages:/gnu/store/g2djv18c2qgaj2law3rg5201w5s374mr-python-setuptools-scm-1.15.0/lib/python3.5/site-packages:/gnu/store/p3rakgmppp6gcb8309x0gz620bwspjny-python-six-1.10.0/lib/python3.5/site-packages:/gnu/store/105aqvn7cizpml0ijq54zhhl27992pr2-python-numpy-1.12.0/lib/python3.5/site-packages:/gnu/store/kyv5jhhn2d9p7vvkzijhr5jj3s84i4qj-python-pandas-0.19.2/lib/python3.5/site-packages:/gnu/store/3aw9x28la9nh8fzkm665d7fywxzbl15j-python-3.5.3/lib/python3.5/site-packages:/gnu/store/s7n625jx3zd4ia2sabfc4kxwzkgx9n17-python-py-1.4.32/lib/python3.5/site-packages:/gnu/store/zfvaglpfb5x3659gi2pqxq7mar5jg4is-python-dateutil-2.6.0/lib/python3.5/site-packages:/gnu/store/zkbdxzygyyn0fqrlsn6szbicf66cxzr0-python-pytz-2017.2/lib/python3.5/site-packages"
export SHLVL="1"
export SOURCE_DATE_EPOCH="1"
export TEMP="/tmp/guix-build-python-pyarrow-0.5.0.drv-0"
export TEMPDIR="/tmp/guix-build-python-pyarrow-0.5.0.drv-0"
export TMP="/tmp/guix-build-python-pyarrow-0.5.0.drv-0"
export TMPDIR="/tmp/guix-build-python-pyarrow-0.5.0.drv-0"
export out="/gnu/store/ix226p2kp97sxzj1s9falg9my004fgpy-python-pyarrow-0.5.0"
{code}

> [Python] User reports pkg-config does not work properly in FindArrow.cmake 
> for pyarrow
> --------------------------------------------------------------------------------------
>
>                 Key: ARROW-1337
>                 URL: https://issues.apache.org/jira/browse/ARROW-1337
>             Project: Apache Arrow
>          Issue Type: Bug
>          Components: Python
>            Reporter: Wes McKinney
>            Assignee: Wes McKinney
>             Fix For: 0.7.0
>
>
> {code}
> -- Checking for module 'arrow'
> --   Found arrow, version 0.5.0
> -- Arrow ABI version: 0.0.0
> -- Arrow SO version: 0
> -- Found the Arrow core library: 
> /gnu/store/h3cb0ynq76cmzs2vp2syqd42kkdh9paa-apache-arrow-0.5.0/lib/libarrow.so
> -- Found the Arrow Python library: 
> /gnu/store/h3cb0ynq76cmzs2vp2syqd42kkdh9paa-apache-arrow-0.5.0/lib/libarrow_python.so
> CMake Error at cmake_modules/BuildUtils.cmake:88 (message):
>   No static or shared library provided for arrow
> Call Stack (most recent call first):
>   CMakeLists.txt:263 (ADD_THIRDPARTY_LIB)
> -- Configuring incomplete, errors occurred!
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to