[ 
https://issues.apache.org/jira/browse/ARROW-1346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16121646#comment-16121646
 ] 

Wes McKinney commented on ARROW-1346:
-------------------------------------

What platform are you on? There are only 0.5.0.post2 binaries for Linux, for 
the other platforms it is still 0.5.0

https://pypi.python.org/pypi/pyarrow

> pypi packages compatible with setuptools
> ----------------------------------------
>
>                 Key: ARROW-1346
>                 URL: https://issues.apache.org/jira/browse/ARROW-1346
>             Project: Apache Arrow
>          Issue Type: Wish
>          Components: Python
>    Affects Versions: 0.5.0
>            Reporter: Antony Mayi
>         Attachments: setup.py
>
>
> setuptools is internally using easy_install for pulling packages from pypi. 
> easy_install doesn't support wheel so since pyarrow is in pypi distributed 
> only as wheels it is not possible to package a product depending on pyarrow 
> using setuptools.
> see attached [^setup.py]:
> {code}
> $ python setup.py test
> running test
> Searching for pyarrow==0.5.0.post2
> Reading https://pypi.python.org/simple/pyarrow/
> No local packages or working download links found for pyarrow==0.5.0.post2
> error: Could not find suitable distribution for 
> Requirement.parse('pyarrow==0.5.0.post2')
> {code}
> It's a shame setuptools don't support wheels. unfortunately it supports only 
> eggs or raw source packages (see 
> [distro_for_location|https://github.com/pypa/setuptools/blob/master/setuptools/package_index.py#L112]).
>  I am not suggesting providing eggs but perhaps publishing raw tar.gz should 
> be considered so that setuptools can at least build the dependency itself.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to