[ 
https://issues.apache.org/jira/browse/ARROW-2464?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16439590#comment-16439590
 ] 

ASF GitHub Bot commented on ARROW-2464:
---------------------------------------

pitrou commented on issue #1879: ARROW-2464: [Python] Use a python_version 
marker instead of a condition
URL: https://github.com/apache/arrow/pull/1879#issuecomment-381646788
 
 
   Yes, it should be ok. Also thanks for explaining the bug on the JIRA issue.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


> [Python] Use a python_version marker instead of a condition
> -----------------------------------------------------------
>
>                 Key: ARROW-2464
>                 URL: https://issues.apache.org/jira/browse/ARROW-2464
>             Project: Apache Arrow
>          Issue Type: Task
>          Components: Packaging, Python
>    Affects Versions: 0.9.0
>            Reporter: Omer Katz
>            Priority: Minor
>              Labels: pull-request-available
>
> When installing pyarrow 0.9.0 pipenv complains that futures has no matching 
> versions.
> While that may be a bug in pipenv it does not matter. The standard way to 
> specify a conditional dependency is using a marker.
> We should use the python_version marker to tell pip if it should install 
> futures or not.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to