[
https://issues.apache.org/jira/browse/ARROW-5745?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16873613#comment-16873613
]
Wes McKinney commented on ARROW-5745:
-------------------------------------
It might make things more clear to call these methods {{MapArray::entry_keys}}
and {{MapArray::entry_values}}. I suspect that having a {{MapValue}} struct
(representing semantically a Python dictionary-alike object) improve the
usability of this class in general
> [C++] properties of Map(Array|Type) are confusingly named
> ---------------------------------------------------------
>
> Key: ARROW-5745
> URL: https://issues.apache.org/jira/browse/ARROW-5745
> Project: Apache Arrow
> Issue Type: New Feature
> Components: C++
> Reporter: Benjamin Kietzman
> Assignee: Benjamin Kietzman
> Priority: Major
>
> In the context of ListArrays, "values" indicates the elements in a slot of
> the ListArray. Since MapArray isa ListArray, "values" indicates the same
> thing and the elements are key-item pairs. This naming scheme is not
> idiomatic; these *should* be called key-value pairs but that would require
> propagating the renaming down to ListArray.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)