[ 
https://issues.apache.org/jira/browse/ARROW-4830?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16932708#comment-16932708
 ] 

Joris Van den Bossche commented on ARROW-4830:
----------------------------------------------

For this, I think we should ideally decide on which minimum version of pyarrow  
we want to support (and then also test for this). Or at least we have something 
to communicate about like: "files written by pyarrow >= xx can be read"

> [Python] Remove backward compatibility hacks from pyarrow.pandas_compat
> -----------------------------------------------------------------------
>
>                 Key: ARROW-4830
>                 URL: https://issues.apache.org/jira/browse/ARROW-4830
>             Project: Apache Arrow
>          Issue Type: Improvement
>          Components: Python
>            Reporter: Wes McKinney
>            Priority: Major
>             Fix For: 1.0.0
>
>
> This code is growing less maintainable. I think we can remove these backwards 
> compatibility hacks since there are released versions of pyarrow that can be 
> used to read old metadata and "fix" Parquet files if need be



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to