Stuart Russell created ARROW-9237:

             Summary: [R] Arch 1.17 install on Arch Linux
                 Key: ARROW-9237
             Project: Apache Arrow
          Issue Type: Bug
          Components: R
    Affects Versions: 0.17.1
         Environment: LSB Version:    1.4
Distributor ID: Arch
Description:    Arch Linux
Release:        rolling
(fully updated)

aur/arrow 0.17.0-1 -
community/grpc 1.29.1-1 -

R Cran arrow 0.17.1

            Reporter: Stuart Russell

As per the installation vignette I'm reporting this installation issue.

I couldn't install the R package by building the C++ libraries as I hit:
# arch arrow install unable to load shared object 
R/x86_64-pc-linux-gnu-library/4.0/00LOCK-arrow/00new/arrow/libs/ : 
undefined symbol: _ZTIN6apache6thrift8protocol9TProtocolE{code}
I tried to set R_LD_LIBRARY_PATH as suggested but it didn't help. Maybe I made 
a mistake.

Using the arrow binary was failing as the version on the Arch AUR was 0.17.0 
while the CRAN version was 0.17.1, and the AUR install was failing because 
there are apparently issues with grpc 1.28+ (I was on 1.29.1).

I finally solved the issue by setting -DARROW_FLIGHT to OFF during installation 
from the AUR ( I also turned -DARROW_WITH_SNAPPY to ON):
yay --editmenu -S arrow
Then to install the R package I had to set NOT_CRAN=true & install the 0.17.0 
packageurl <- 
install.packages(packageurl, repos=NULL, type="source")
This led to a working R install, but I never solved my issue compiling the C++ 
binaries during R install. Perhaps this relates to the same issue with grpc?

I'm sorry I didn't save all the error messages I hit, but I hope it helps.

This message was sent by Atlassian Jira

Reply via email to