davlee1972 opened a new issue, #41381: URL: https://github.com/apache/arrow/issues/41381
### Describe the enhancement requested There are several functions within DataSet that take a @column argument. This include pyarrow.dataset.to_table, pyarrow.dataset.head() and pyarrow.dataset.scanner(), etc.. __filename is a special field.. Can we add **__fileinfo** as a special field? Maybe this should be called **__stat** instead? **Additional FileInfo fields:** mtime[datetime] The modification time of the filesystem entry. If a float is given, it is the number of seconds since the Unix epoch. mtime_ns The modification time of the filesystem entry, in nanoseconds since the Unix epoch. mtime and mtime_ns are mutually exclusive. size[int] **Stat fields:** st_mode − protection bits. st_ino − inode number. st_dev − device. st_nlink − number of hard links. st_uid − user id of owner. st_gid − group id of owner. st_size − size of file, in bytes. st_atime − time of most recent access. st_mtime − time of most recent content modification. st_ctime − time of most recent metadata change. ----------------------- "The list of columns or expressions may use the special fields __batch_index (the index of the batch within the fragment), __fragment_index (the index of the fragment within the dataset), __last_in_fragment (whether the batch is last in fragment), and __filename (the name of the source file or a description of the source fragment)." ### Component(s) C++, Python -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected]
