[ 
https://issues.apache.org/jira/browse/CALCITE-1519?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15711614#comment-15711614
 ] 

Julian Hyde commented on CALCITE-1519:
--------------------------------------

Can someone please review and +1? I know there are breaking changes here, but I 
believe they will not affect most users, and will require only a few minor, 
obvious changes for the rest.

> Standardize on "sub-query" rather than "subquery" in class names and comments
> -----------------------------------------------------------------------------
>
>                 Key: CALCITE-1519
>                 URL: https://issues.apache.org/jira/browse/CALCITE-1519
>             Project: Calcite
>          Issue Type: Bug
>            Reporter: Julian Hyde
>            Assignee: Julian Hyde
>
> I know it's foolish consistency, but this one has been bugging me for a long 
> time. Let's standardize on "sub-query" rather than "subquery" in class names 
> and comments.
> Here are the public and protected Java names that would change:
> * public interface SubqueryConverter becomes SubQueryConverter
> * public enum RelOptUtil.SubqueryType becomes SubQueryType
> * public void SqlPrettyWriter.setSubqueryStyle() becomes setSubQueryStyle
> * public void SqlToRelConverter.setSubqueryConverter() becomes 
> setSubQueryConverter
> * public boolean SqlToRelConverter.canConvertSubquery() becomes 
> canConvertSubQuery
> * public boolean SqlToRelConverter.convertSubquery() becomes convertSubQuery
> * public SqlToRelConverter.Config.getInSubqueryThreshold() becomes 
> getInSubQueryThreshold
> These are breaking changes, but will be easy to identify and fix by just 
> compiling the code, and the APIs are not widely used.
> The following will change, but leave behind the old name deprecated until 2.0:
> * public static final int SqlToRelConverter.DEFAULT_IN_SUBQUERY_THRESHOLD
> * public ConfigBuilder ConfigBuilder.withInSubqueryThreshold
> * public static Programs.subquery()
> * SqlAbstractParserImpl.ACCEPT_SUBQUERY becomes ACCEPT_SUB_QUERY
> * SqlAbstractParserImpl.ACCEPT_NONQUERY becomes ACCEPT_NON_QUERY
> Also a whole bunch of test names will change, and private/package-protected 
> members, but that should not affect anyone.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to