[ 
https://issues.apache.org/jira/browse/CALCITE-3418?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Rui Wang resolved CALCITE-3418.
-------------------------------
    Fix Version/s: 1.22.0
       Resolution: Fixed

> Grouped Window Function TUMBLE should return "$TUMBLE" as its operator name
> ---------------------------------------------------------------------------
>
>                 Key: CALCITE-3418
>                 URL: https://issues.apache.org/jira/browse/CALCITE-3418
>             Project: Calcite
>          Issue Type: Sub-task
>            Reporter: Rui Wang
>            Assignee: Rui Wang
>            Priority: Major
>              Labels: pull-request-available
>             Fix For: 1.22.0
>
>          Time Spent: 2.5h
>  Remaining Estimate: 0h
>
> In CALCITE-3382, we renamed Grouped Window Function TUMBLE to "$TUMBLE" but 
> still decided to return "TUMBLE"  as the operator name. It turns out, in 
> order to avoid operator overloading and continue working on CALCITE-3340,  
> TUMBLE should return "$TUMBLE" as its name.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to