[
https://issues.apache.org/jira/browse/CAMEL-7324?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13945313#comment-13945313
]
Rene Avontuur commented on CAMEL-7324:
--------------------------------------
RoutingSlip.java appears to contain untested duplicated code (below public
boolean doInAsyncProducer), that probably needs the same kind of code-change.
> DynamicRouter sends in-message to next destination
> --------------------------------------------------
>
> Key: CAMEL-7324
> URL: https://issues.apache.org/jira/browse/CAMEL-7324
> Project: Camel
> Issue Type: Bug
> Components: camel-core
> Reporter: Rene Avontuur
> Attachments: DynamicRouterIntermediateResultIssueTest.java,
> patch7324.txt
>
>
> The DynamicRouter appears to send the in-message in stead of the out-message
> to the next destination, which is an unexpected behaviour.
--
This message was sent by Atlassian JIRA
(v6.2#6252)