[ 
https://issues.apache.org/jira/browse/CAMEL-11096?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16004349#comment-16004349
 ] 

Claus Ibsen commented on CAMEL-11096:
-------------------------------------

At first thought I dont think so as the current model resemble the 
camel-catalog very closely.

I think your model convolutes things and now you add eg readOnly which is not 
something we have in camel-catalog.
The current model is fairly easy to reason as its separated

- endpointOptions = the options the connector supports the user to see/use
- endpointValues = override or set any default values you want, also for hidden 
options that are not listed in endpointOptions

- endpointOverrides = to override the option from the camel-catalog (we should 
maybe come up with a new name), but this allows you to change anything there 
you like such as its description, enum values, etc. This one is more 
hard-core/advanced.

This makes the model easier for new users as the first two are basic, and the 
latter more advanced. 

> Connector semantics with respect to default values
> --------------------------------------------------
>
>                 Key: CAMEL-11096
>                 URL: https://issues.apache.org/jira/browse/CAMEL-11096
>             Project: Camel
>          Issue Type: Task
>          Components: camel-connector
>    Affects Versions: 2.19.0
>            Reporter: Roland Huss
>            Priority: Minor
>
> I would like to discuss the semantics of default parameters for connectors. 
> Currently a user can override 'frozen' (== pre-configured) component options 
> when [creating the 
> endpoint|https://github.com/apache/camel/blob/bc9d07700678604ae43754a32519898c47bb9529/connectors/camel-connector/src/main/java/org/apache/camel/component/connector/DefaultConnectorComponent.java#L261]
> I wonder whether this is the desired behaviour ? E.g. when creating a 
> `salesforce-upsert-connector` and letting override the "operationName" (which 
> was preconfigured in the connector) defeats its purpose imo. (Although it was 
> just quite helpful in my case ;-)
> Of course the ideal solution would be to mark options as overridable or not.
> What do you think ?



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Reply via email to