[ 
https://issues.apache.org/jira/browse/CAMEL-9751?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16115900#comment-16115900
 ] 

Marco Santarelli commented on CAMEL-9751:
-----------------------------------------

Agree with [~tdudgeon], it would be nice to have the option to specify the 
security requirements as defined in 
https://swagger.io/specification/#securitySchemeObject
Swagger-UI 3+ does not allow to override headers easily anymore, and relies 
solely on these specs in the swagger.json to build the UI accordingly.

> Add support for security requirements to swagger java component
> ---------------------------------------------------------------
>
>                 Key: CAMEL-9751
>                 URL: https://issues.apache.org/jira/browse/CAMEL-9751
>             Project: Camel
>          Issue Type: New Feature
>          Components: camel-swagger
>            Reporter: Tim Dudgeon
>            Priority: Minor
>             Fix For: 2.20.0
>
>
> Swagger Java component does not currently allow security requirements to be 
> specified. Would be useful to be able to do so.
> But as security is usually applied at the container level its not clear what 
> the best approach would be. 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to