[ 
https://issues.apache.org/jira/browse/CAMEL-11915?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Flemming Harms updated CAMEL-11915:
-----------------------------------
    Description: 
Minor mistake in the new elasticsearch5-rest dokumentation.

* The operation names is wrong and should reflect the names in the 
ElasticsearchOperation
* The maven pom.xml example pointing to the wrong artifact

A few of the operation type is returning a incorrect Type from body
- Update should return an Object from the body instead of Map and pas it into 
the ElasticsearchActionRequestConverter.toUpdateRequest
- Bulk should return an Object and pas it into the 
ElasticsearchActionRequestConverter.toBulkRequest

  was:
Minor mistake in the new elasticsearch5-rest dokumentation.

* The operation names is wrong and should reflect the names in the 
ElasticsearchOperation
* The maven pom.xml example pointing to the wrong artifact

A few of the operation type is returning a incorrect Type from body
- Update should return an Object from the body instead of Map and pas into the 
ElasticsearchActionRequestConverter.toUpdateRequest
- Bulk should return an Object and pas into the 
ElasticsearchActionRequestConverter.toBulkRequest


> Fix incorrect elasticsearch5-rest documentation and OperationTypes
> ------------------------------------------------------------------
>
>                 Key: CAMEL-11915
>                 URL: https://issues.apache.org/jira/browse/CAMEL-11915
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-elasticsearch5
>    Affects Versions: 2.21.0
>            Reporter: Flemming Harms
>            Assignee: Flemming Harms
>            Priority: Minor
>
> Minor mistake in the new elasticsearch5-rest dokumentation.
> * The operation names is wrong and should reflect the names in the 
> ElasticsearchOperation
> * The maven pom.xml example pointing to the wrong artifact
> A few of the operation type is returning a incorrect Type from body
> - Update should return an Object from the body instead of Map and pas it into 
> the ElasticsearchActionRequestConverter.toUpdateRequest
> - Bulk should return an Object and pas it into the 
> ElasticsearchActionRequestConverter.toBulkRequest



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to