[ 
https://issues.apache.org/jira/browse/CAMEL-14788?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17067296#comment-17067296
 ] 

Pedro Catalão commented on CAMEL-14788:
---------------------------------------

Hi Claus, thanks for looking into it. I'm not sure if I understand what you 
mean.

When I add Jetty directly to Karaf, I still get the exact same error :\
{code:java}
[INFO] Feature camel-jetty9/2.24.3 is defined as a boot feature
[INFO] adding maven artifact: 
mvn:org.eclipse.jetty/jetty-server/9.4.25.v20191220{code}
{code:java}
243 │ Active │ 80 │ 9.4.25.v20191220 │ Jetty :: Http Utility
245 │ Active │ 80 │ 9.4.25.v20191220 │ Jetty :: IO Utility
254 │ Active │ 80 │ 9.4.25.v20191220 │ Jetty :: Server Core
258 │ Active │ 80 │ 9.4.25.v20191220 │ Jetty :: Utilities{code}
 

Shall I pinpoint {color:#0747a6}camel-jetty{color}'s version to a version prior 
to the issue or can you think of a better way to tackle this?

 

Thanks,

Pedro

> Unable to Start Jetty server in OSGi environment
> ------------------------------------------------
>
>                 Key: CAMEL-14788
>                 URL: https://issues.apache.org/jira/browse/CAMEL-14788
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-jetty
>    Affects Versions: 2.24.3
>            Reporter: Pedro Catalão
>            Assignee: Claus Ibsen
>            Priority: Major
>             Fix For: 2.25.1, 3.2.0
>
>
> When deploying a spring XML via Karaf containing the Jetty component such as:
> {code:java}
> <route id="9de65790-5809-11ea-aafe-874a8d3d85de">
>  <from uri="jetty:http://0.0.0.0:9000/test"/>
>  <to 
> uri="activemq:ID_5e5520ab59931d2df0000203_test_9de65790-5809-11ea-aafe-874a8d3d85de"/>
>  </route>
>  <route id="88ecf240-57d2-11ea-be9a-2d059f74df24">
>  <from 
> uri="activemq:ID_5e5520ab59931d2df0000203_test_9de65790-5809-11ea-aafe-874a8d3d85de"/>
>  <to uri="foobar"/>
>  </route>{code}
>  
> Got this exception:
> {code:java}
> java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: 
> org/eclipse/jetty/server/MultiPartFormDataCompliancejava.util.concurrent.ExecutionException:
>  java.lang.NoClassDefFoundError: 
> org/eclipse/jetty/server/MultiPartFormDataCompliance at 
> java.util.concurrent.FutureTask.report(FutureTask.java:122) ~[?:?]Caused by: 
> java.lang.ClassNotFoundException: 
> org.eclipse.jetty.server.MultiPartFormDataCompliance not found by 
> org.eclipse.jetty.server [251] {code}
>   
> While investigating found that Camel *{color:#172b4d}2.24.3{color}* uses 
> Jetty *{color:#172b4d}9.4.12.v20180830{color}* which is affected by this 
> issue: [https://github.com/eclipse/jetty.project/issues/4350]
>  
> This has been fixed in Jetty >= *{color:#172b4d}9.4.25{color}* by rolling 
> back the explicit exclusion of 
> {color:#ff0000}MultiPartInputStreamParser{color}
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to