[ 
https://issues.apache.org/jira/browse/CLOUDSTACK-10147?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16350010#comment-16350010
 ] 

ASF GitHub Bot commented on CLOUDSTACK-10147:
---------------------------------------------

houthuis opened a new pull request #2442: CLOUDSTACK-10147 Disabled Xenserver 
Cluster can still deploy VM's
URL: https://github.com/apache/cloudstack/pull/2442
 
 
   ENVIRONMENT 
   ===================== 
   XenServer Version : 6.2 , 7
   
   ISSUE 
   ================== 
   Disabled Xenserver Cluster can still deploy VM's , hosts in the cluster are 
still active
   
   Repro. steps followed 
   ================== 
   Disabled Cluster from UI. 
   Deploy a new VM
   
   Expected Behavior 
   ===============
   After disabling the cluster , the hosts should be disabled. and no VM's can 
be deployed
   
   Note:
   it's the same results for XenServer or simulator, can't deploy on disabled 
hosts, but can deploy on disabled cluster
   
   Solution:
   
   Added a check to skip disabled clusters when selecting a host to deploy on.
   Deploying on a disabled cluster will now result in a 
InsufficientServerCapacityException, if no enabled clusters are found.
   
   i didn't want to propagate disabling a cluster down to the hosts, because 
then you would have to enable all the hosts again when you enable the cluster, 
and we won't know which hosts should be left in a disabled state

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
us...@infra.apache.org


> Disabled Xenserver cluster can still deploy VMs 
> ------------------------------------------------
>
>                 Key: CLOUDSTACK-10147
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10147
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the 
> default.) 
>          Components: Management Server, UI
>    Affects Versions: 4.10.0.0, 4.9.2.0
>         Environment: Xenserver 6.2, 7
>            Reporter: Glenn Wagner
>            Assignee: Henko Holtzhausen
>            Priority: Major
>
> ENVIRONMENT 
> ===================== 
> XenServer Version : 6.2 , 7
> ISSUE 
> ================== 
> Disabled Xenserver Cluster can still deploy VM's , hosts in the cluster are 
> still active  
> Repro. steps followed 
> ================== 
> Disabled Cluster from UI. 
> Deploy a new VM 
> Expected Behavior 
> ===============
> After disabling the cluster , the hosts should be disabled. and no VM's can 
> be deployed 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to