KuiLIU created CLOUDSTACK-10362:
-----------------------------------

             Summary: Inconsistent method names
                 Key: CLOUDSTACK-10362
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10362
             Project: CloudStack
          Issue Type: Improvement
      Security Level: Public (Anyone can view this level - this is the default.)
            Reporter: KuiLIU


Some Boolean-return methods are named "getXXX",
but other Boolean-return methods are named "isXXX", such as the following two 
methods.
They will return boolean values, rename them as "isXXX" should be more clear 
than "getXXX".

api/src/main/java/org/apache/cloudstack/api/command/admin/vlan/ListVlanIpRangesCmd.java
{code:java}
     public Boolean getForVirtualNetwork() {
         return forVirtualNetwork;
     }
{code}
api/src/main/java/org/apache/cloudstack/api/command/user/address/ListPublicIpAddressesCmd.java
{code:java}
    public Boolean isForVirtualNetwork() {
        return forVirtualNetwork;
    }
{code}




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to