[ 
https://issues.apache.org/jira/browse/CLOUDSTACK-10360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16458374#comment-16458374
 ] 

ASF subversion and git services commented on CLOUDSTACK-10360:
--------------------------------------------------------------

Commit 93509a431cde8452037e79f7b85584a2a3c025df in cloudstack's branch 
refs/heads/master from [~BruceKuiLIU]
[ https://gitbox.apache.org/repos/asf?p=cloudstack.git;h=93509a4 ]

CLOUDSTACK-10360: Change the method name. (#2598)

The method is named as "scoped" that seems to whether the variable config is 
scoped in _scopedStorages or not. Actually, the method tries to find a storage 
of which scope equals to the scope of config. So that, the method name 
"findStorage" should be more clear than "scoped".


> Inconsistent method name
> ------------------------
>
>                 Key: CLOUDSTACK-10360
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10360
>             Project: CloudStack
>          Issue Type: Improvement
>      Security Level: Public(Anyone can view this level - this is the 
> default.) 
>            Reporter: KuiLIU
>            Priority: Major
>
> The following method is named as "scoped" that seems to whether the variable 
> config is scoped in _scopedStorages or not.
> Actually, the method tries to find a storage of which scope equals to the 
> scope of config.
> So that, the method name "findStorage" should be more clear than "scoped".
> {code:java}
>     public ScopedConfigStorage scoped(ConfigKey<?> config) {
>         for (ScopedConfigStorage storage : _scopedStorages) {
>             if (storage.getScope() == config.scope()) {
>                 return storage;
>             }
>         }
>         throw new CloudRuntimeException("Unable to find config storage for 
> this scope: " + config.scope() + " for " + config.key());
>     }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to