[ 
https://issues.apache.org/jira/browse/STATISTICS-6?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17959697#comment-17959697
 ] 

Gilles Sadowski commented on STATISTICS-6:
------------------------------------------

{quote}
{code}
public enum BinomialConfidenceLevel { /* ... */ }
{code}
{quote}

Shouldn't this be named {{BinomialConfidenceInterval}} ?

bq. Remove the confidence level from the interface.

+1

But then the {{ConfidenceInterval}} interface becomes a (trivial) "interval", 
or actually just a "pair of numbers".
Shouldn't this be defined at a more general level?

bq. Change from using confidence level to target error rate alpha

Even if one method would trivially call the other, how about having two factory 
methods:
{code}
public ConfidenceInterval withConfidenceLevel(int numberOfTrials, int 
numberOfSuccesses, double confidence) {
  return withErrorRate(numberOfTrials, numberOfSuccesses, 1 - confidence);
}
{code}
and
{code}
public ConfidenceInterval withErrorRate(int numberOfTrials, int 
numberOfSuccesses, double errorRate) { /* ... */ }
{code}
?


> Package "o.a.c.math4.stat.interval"
> -----------------------------------
>
>                 Key: STATISTICS-6
>                 URL: https://issues.apache.org/jira/browse/STATISTICS-6
>             Project: Commons Statistics
>          Issue Type: Sub-task
>            Reporter: Gimo
>            Priority: Minor
>              Labels: design, documentation, port
>
> Porting "confidence interval" functionality from "Commons Math".



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to