[
https://issues.apache.org/jira/browse/MATH-944?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13817407#comment-13817407
]
Thomas Neidhart commented on MATH-944:
--------------------------------------
We could already provide a generic version for the Frequency class before the
4.0 release, we would just have to name it differently.
This would also allow to keep the old one, in case some users prefer it like
that.
Any ideas on a name?
My thoughts:
* Frequency2
* GenericFrequency
* TypedFrequency
> Consider making a generic version of class Frequency
> ----------------------------------------------------
>
> Key: MATH-944
> URL: https://issues.apache.org/jira/browse/MATH-944
> Project: Commons Math
> Issue Type: Improvement
> Affects Versions: 3.1
> Reporter: Thomas Neidhart
> Priority: Minor
> Fix For: 4.0
>
> Attachments: Frequency.java
>
>
> The current version of the Frequency class is quite complex, as it has to
> handle different input values and does a lot of casting.
> The class is also not very safe in the sense that adding different data types
> will lead to runtime exceptions.
> The class could be simplified by introducing a generic version. The only
> downside so far is that the current version treats ints and longs together,
> which would not be possible with a generic version.
--
This message was sent by Atlassian JIRA
(v6.1#6144)