[
https://issues.apache.org/jira/browse/CRYPTO-12?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15255799#comment-15255799
]
Jerry Chen commented on CRYPTO-12:
----------------------------------
Thanks Xianda. I am +1 for the name proposal.
"Cipher" prefix may be a better name. This name convention can also includes
other stream classes, such as:
CTRCipherInputStream, CTRCipherOutputStream, PositiontedCipherInputStream.
> Names of CryptoInputStream & CryptoOutputStream
> -----------------------------------------------
>
> Key: CRYPTO-12
> URL: https://issues.apache.org/jira/browse/CRYPTO-12
> Project: Commons Crypto
> Issue Type: Improvement
> Reporter: Xianda Ke
>
> It seems that "{color:red}Cipher{color}InputStream" and
> ''{color:red}Cipher{color}OutputStream' are more friendly to the users who
> are familar with Java Cryptography Extension(JCE).
> Java(JCE) use the name 'CipherInputStream' and 'CipherOutputStream'
> (see javax.crypto.CipherInputStream & javax.crypto.CipherOutputStream).
> btw, Bouncy Castle Crypto library also use the name
> '[CipherInputStream|https://github.com/bcgit/bc-java/blob/master/core/src/main/java/org/bouncycastle/crypto/io/CipherInputStream.java]'
> and
> '[CipherOutputStream|https://github.com/bcgit/bc-java/blob/master/core/src/main/java/org/bouncycastle/crypto/io/CipherOutputStream.java]'.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)