Bruno P. Kinoshita commented on LANG-1269:

Indeed Benedikt. I'll file a ticket for [text].

If methods like this are going to be deprecated (and maybe removed in the 4.x 
release?) in [lang], then I'd think we should just add the @deprecated 
annotation to the method. Other wise, I'd be inclined to leave the method name 
as-is (so we keep binary compatibility), return 1 - currentResult as suggested 
by [~jmkeil]; and maybe update the Javadocs as well.

> Wrong name or result of StringUtils::getJaroWinklerDistance
> -----------------------------------------------------------
>                 Key: LANG-1269
>                 URL: https://issues.apache.org/jira/browse/LANG-1269
>             Project: Commons Lang
>          Issue Type: Bug
>    Affects Versions: 3.3, 3.4
>            Reporter: Jan Martin Keil
>            Assignee: Bruno P. Kinoshita
>            Priority: Minor
> The name of the method StringUtils::getJaroWinklerDistance is misleading.
> Currently for equal strings {{1}} is returned, for completely different 
> strings {{0}} is returned. That is a measure of similarity, not of a 
> distance. A distance must be {{0}} for equal strings. I read on the issues 
> LANG-591 and LANG-944, that it was decided to have a similar name to 
> StringUtils::getLevenshteinDistance, but that requires also the change of the 
> methods result.
> Could you please (1) rename the method to 
> StringUtils::getJaroWinklerSimilarity or (2) change the method to return {{1 
> - currentResult}}?
> First option has the disadvantage to lose the similar naming of the similar 
> methods, second option implies the risk to unnoticed introduce bugs in 
> depending code. So I think it is preferable to use the first option.

This message was sent by Atlassian JIRA

Reply via email to