[ 
https://issues.apache.org/jira/browse/LANG-1389?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16429790#comment-16429790
 ] 

Michael Osipov commented on LANG-1389:
--------------------------------------

This was not my intention. The intention was to indicate that this enum is 
error-prone and can be safely replaced with the new Java 9 implementation. For 
those who still rely on it, should not fall in the same pitfalll like we do. I 
see no reason maintaining this class in the future when Lang will require Java 
11 LTS.

> Deprecate JavaVersion in favor of java.lang.Runtime.Version
> -----------------------------------------------------------
>
>                 Key: LANG-1389
>                 URL: https://issues.apache.org/jira/browse/LANG-1389
>             Project: Commons Lang
>          Issue Type: Task
>          Components: lang.*
>    Affects Versions: 3.7
>            Reporter: Michael Osipov
>            Priority: Major
>
> With the rapid release cycle of Java {{JavaVersion}} does not really work 
> anymore. We at Maven have constant issues with our subprojects for missing 
> Java version in {{JavaVersion}} enum. To solve this problem, Commons Lang 
> must be release at least every six months and we have re-release all affected 
> components. Since this does not scale, I would recommend to deprecate this 
> enum in favor of {{java.lang.Runtime.Version}} or have a better non-enum 
> approach to it.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to