[ 
https://issues.apache.org/jira/browse/CXF-6705?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Colm O hEigeartaigh closed CXF-6705.
------------------------------------

> Incorrect version in Import-Package for javax.validation for CXF Core
> ---------------------------------------------------------------------
>
>                 Key: CXF-6705
>                 URL: https://issues.apache.org/jira/browse/CXF-6705
>             Project: CXF
>          Issue Type: Bug
>            Reporter: Benson Margulies
>            Assignee: Benson Margulies
>             Fix For: 3.1.5, 3.2.0
>
>
> I believe that the following are wrong. The versions exported by the 
> servicemix jar are 1.0.0.
> {noformat}
>       javax.validation;resolution:=optional;version=1.1.0.Final,
>       javax.validation.bootstrap;resolution:=optional;version=1.1.0.Final,
>       javax.validation.executable;resolution:=optional;version=1.1.0.Final,
>       javax.validation.spi;resolution:=optional;version=1.1.0.Final,
> {noformat}
> Here's what servicemix exports:
> {noformat}
> xport-Package =
>       javax.validation;
>               uses:="javax.validation.bootstrap,
>                       javax.validation.executable,
>                       javax.validation.metadata,
>                       javax.validation.spi";
>               version=1.0.0,
>       javax.validation.bootstrap;uses:=javax.validation;version=1.0.0,
>       javax.validation.constraints;uses:=javax.validation;version=1.0.0,
>       javax.validation.constraintvalidation;version=1.0.0,
>       javax.validation.executable;uses:=javax.validation;version=1.0.0,
>       javax.validation.groups;version=1.0.0,
>       javax.validation.metadata;uses:=javax.validation;version=1.0.0,
>       javax.validation.spi;uses:=javax.validation;version=1.0.0
> {noformat}
> It's been a while, but I think I can make a fix to this.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to