[ 
https://issues.apache.org/jira/browse/DRILL-5710?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Angel Aray updated DRILL-5710:
------------------------------
    Summary: drill-config.sh incorrectly exits with Java 1.7 or later is 
required to run Apache Drill  (was: drill-config.sh incorrectly exits with Java 
1.7 or later is required to run Apache Dril)

> drill-config.sh incorrectly exits with Java 1.7 or later is required to run 
> Apache Drill
> ----------------------------------------------------------------------------------------
>
>                 Key: DRILL-5710
>                 URL: https://issues.apache.org/jira/browse/DRILL-5710
>             Project: Apache Drill
>          Issue Type: Bug
>    Affects Versions: 1.11.0
>         Environment: java version "1.8.0_144"
> OSX
>            Reporter: Angel Aray
>
> drill-config fails to recognize 1.8.0_144 as Java 1.7 or later.
> The scripts validates the java version using the following code:
> "$JAVA" -version 2>&1 | grep "version" | egrep -e "1.4|1.5|1.6" 
> this should be replaced by:
> "$JAVA" -version 2>&1 | grep "version" | egrep -e "1\.4|1\.5|1\.6" 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to