[ 
https://issues.apache.org/jira/browse/DRILL-6409?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16540258#comment-16540258
 ] 

Peter Kfoury commented on DRILL-6409:
-------------------------------------

I am getting this error when querying Decimal182 data from mongo. It looks like 
Drill uses mongo-java-driver version 3.2.0, and this bug was supposedly fixed 
in 3.4. I tried rebuilding Drill with driver 3.8.0 and I'm still getting the 
error

> Query Failed: An Error Occurred
> -------------------------------
>
>                 Key: DRILL-6409
>                 URL: https://issues.apache.org/jira/browse/DRILL-6409
>             Project: Apache Drill
>          Issue Type: Bug
>            Reporter: JUDILSON JOSE DA COSTA JUNIOR
>            Priority: Major
>         Attachments: Test.rar, erro_drill.png, 
> erro_drill_det_mongo-java-driver-3.2.0.png, 
> erro_drill_det_mongo-java-driver-3.7.0.png
>
>
> h2. Query Failed: An Error Occurred
> org.apache.drill.common.exceptions.UserRemoteException: INTERNAL_ERROR ERROR: 
> UnSupported Bson type: DECIMAL128 Fragment 0:0 [Error Id: 
> 35c951e0-3ce7-4232-8a90-1c146ecc749f on DSK-0244.eicon.com.br:31010]
> Verison mongo-java-driver: 3.7.0
> Version mongo: 3.4



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to