[ 
https://issues.apache.org/jira/browse/DRILL-6225?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Rob Wu updated DRILL-6225:
--------------------------
    Summary: Add support for boost 1.64+ with openSSL 1.1.0 support  (was: Add 
support for boost 1.63+ with openSSL 1.1.0 support)

> Add support for boost 1.64+ with openSSL 1.1.0 support
> ------------------------------------------------------
>
>                 Key: DRILL-6225
>                 URL: https://issues.apache.org/jira/browse/DRILL-6225
>             Project: Apache Drill
>          Issue Type: Task
>          Components: Client - C++
>            Reporter: Rob Wu
>            Priority: Minor
>
> Boost 1.57 is not able to compile with openSSL 1.1 
> ([https://svn.boost.org/trac10/ticket/12238)] and adding 
> add_definitions(-DOPENSSL_API_COMPAT=0x10000000L) does not work. 
>  
> In order to add support for openSSL 1.1, we would need to upgrade boost to 
> 1.62+. However, it looks like boost 1.62 bcp will segfault on asio component 
> when you attempt to shade the boost libraries 
> ([https://svn.boost.org/trac10/ticket/12357)]. So in that case, we should 
> upgrade to 1.63+.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to