[ 
https://issues.apache.org/jira/browse/FINERACT-2464?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Adam Saghy resolved FINERACT-2464.
----------------------------------
    Fix Version/s: 1.15.0
       Resolution: Fixed

> Refactor LoanScheduleAssembler to reduce complexity in 
> assembleLoanScheduleFrom
> -------------------------------------------------------------------------------
>
>                 Key: FINERACT-2464
>                 URL: https://issues.apache.org/jira/browse/FINERACT-2464
>             Project: Apache Fineract
>          Issue Type: Improvement
>          Components: Loan
>            Reporter: saifulhuq
>            Priority: Minor
>             Fix For: 1.15.0
>
>
> The method `assembleLoanScheduleFrom` in `LoanScheduleAssembler.java` 
> currently contains inline logic for handling "Equal Amortization" 
> calculations combined with "Declining Balance" interest checks.
> This inline logic adds cognitive load and increases the complexity of the 
> method, making it harder to read and maintain.
> Changes:
> - Extracted the "Equal Amortization" interest update logic into a private 
> helper method `updateInterestForEqualAmortization`.
> - Simplified the conditional logic in the main `assembleLoanScheduleFrom` 
> method.
> - Improved code readability and adherence to Clean Code principles.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to